Spis treści

  • Informacje wstępne
  • Dokumentacja
  • Konfiguracja sprzętu i środowiska
  • Zgodność Systemu z Ustawą o rachunkowości
  • Instalacja
  • Informacje techniczne
  • Podstawowe dane organizacyjne Systemu
  • Dane wprowadzane do Systemu
  • Realizacja obiegu dokumentów
  • Zasady przetwarzania roku obrachunkowego
  • Podstawowe zasady obsługi
  • Dostęp do danych
  • Informacje techniczne
  • Zabezpieczenie danych

Copyright © 2012 PI Rol-Tech


Wersje - zmiany

Informacje wstępne

    Niniejsza dokumentacja przedstawia :
  • Jak programy realizują postanowienia Ustawy o Rachunkowości.
  • Podstawowe informacje o zasadach obsługi programów.
  • Sposoby zabezpieczenia danych :
    • Ustawianie praw dostępu poszczególnych osób do programów , funkcji i danych.
    • Wykonywanie kopii zapasowych i zarządzanie nimi.
  • Informacje techniczne o programach - rodzaje plików, ich rozmieszczenie, przeznaczenie i zawartość informacyjna.


Zgodność Systemu z przepisami prawnymi o rachunkowości

Niniejszy rozdział zawiera informacje dla biegłych badających bilans. Omówione są podstawowe zasady, które musi spełniać system komputerowy i sposób jego użytkowania, aby zachować zgodność z Ustawą i przepisami szczegółowymi.

  • Aby utrzymać zgodność programów autorstwa PI RolTech z przepisami prawnymi konieczne jest:
  • zapewnienie przez PI "ROL-TECH" programów spełniających wymogi Ustawy, czynności te oznaczane są w niniejszym punkcie jako [A] – autorzy,
  • poprawne wykorzystywanie możliwości dostarczonego oprogramowania (zgodne z instrukcja), czynności te oznaczane są w niniejszym punkcie jako [U] - Użytkownik.
Poniżej są wyszczególnione paragrafy i punkty Ustawy o rachunkowości (w szczególności rozdział 2 Prowadzenie ksiąg rachunkowych) oraz opis w jaki sposób są realizowane te postanowienia.
Art. 9 - Język ksiąg
Programy zapewniają prowadzenie ksiąg rachunkowych w języku polskim i w walucie polskiej. Umożliwia przeliczanie wartości ujętych na dokumentach księgowych z walut obcych na polską, po aktualnych kursach. [A]
Art. 10 - Dokumentacja
Program dostosowuje się do przyjętej polityki rachunkowej jednostki, w szczególności do tych jej elementów, co do których ustawa, w określonym zakresie, pozostawia jednostkom wolną rękę: Posiadanie dokumentacji opisującej przyjęte przez jednostkę zasady rachunkowości. [A]
Art. 10 ust. 1 punkt 1
Rok obrotowy i wchodzące w jego skład miesiące obrachunkowe ustala Użytkownik. [U]
Art. 10 ust. 1 punkt 2
Metody wyceny aktywów i pasywów oraz ustalenie wyniku finansowego ustala Użytkownik. [U]
Art. 10 ust. 1 punkt 3.a
  • Zakładowy Plan Kont ( wykaz kont księgi głównej, przyjęte zasady klasyfikacji zdarzeń, prowadzenie ksiąg pomocniczych oraz ich powiązania z kontami księgi głównej ) określa Użytkownik. [U]
  • Oprogramowanie komputerowe zapewnia wprowadzanie do komputera oraz drukowanie Planów Kont w postaci syntetyki i analityk. [A]
  • Wprowadzanie danych oraz drukowania ich dokonuje Użytkownik. [U]
Art. 10 ust 1 punkt 3.b oraz 3.c
W rozdziale Informacje techniczne niniejszej dokumentacji opisane są zasady rozmieszczenia plików, przeznaczeniu oraz informacje o ich zawartości informacyjnej. [A]
    Opis oprogramowania i zasad funkcjonowania jest przedstawiony:
  • ogólnie - w rozdziale "zasady obsługi",
  • szczegółowo - w dokumentacji programu (działanie poszczególnych programów, zasady wykorzystania, opis przetwarzania danych, kontrola ich poprawności).
    Zabezpieczenie dostępu do programów i danych można wykonać z użyciem:
  • mechanizmów wbudowanych w program [U],
  • oraz możliwości systemu operacyjnego Windows [U].
    Dokładniejszy opis znajduje się w rozdziale Dostęp do danych.
    O wersji zakupionego oprogramowania i dacie rozpoczęcia eksploatacji programu decyduje Użytkownik. [U]
    Wszystkie wydruki oraz ekrany programu są oznaczone wersją programu. [A]
Art. 10 ust.1 punkt 4
  • Sposoby zabezpieczenia danych przed ich utratą opisane są w rozdziale Kopie danych [A+U]
  • Zasady ewidencji przebiegu przetwarzania danych opisane są w dokumentacji danego programu. [A]
Art. 12 ust.4
Ostateczne zamknięcie ksiąg rachunkowych
  • Ostateczne zamknięcie ksiąg rachunkowych w programie dokonuje uprawniony Użytkownik. [U]
Art. 12 ust.5
Zamknięcie ksiąg rachunkowych polega na nieodwracalnym wyłączeniu możliwości dokonywania zapisów księgowych w zbiorach tworzących zamknięte księgi rachunkowe, z uwzględnieniem art. 13 ust. 2 i 3.
  • Okres obrachunkowy można zamknąć za pomocą funkcji w module Administracja->Zestawy->Zamknięcie okresu obrachunkowego [A]
  • Po zamknięciu okresu obrachunkowego w programie wyświetlany jest komunikat [Tylko do odczytu - okres zamknięty]. [A]
  • Wówczas Użytkownicy programu nie mają możliwości dokonywania zamian w zamkniętym okresie (roku), ale w ramach przydzielonych uprawnień do funkcji mogą przeglądać dane oraz wykonywać zestawienia.[A+U]
Art. 13 ust.1
Księgi rachunkowe obejmują:
  • punkt 1: Dziennik - każdy dekret zaksięgowany na konta księgowe jest ewidencjonowany w dzienniku księgowań ( zbiór BDZ.RT ). Jest on jest dostępny z modułu FK menu DZIENNIK do przeglądania lub wykonania potrzebnych wydruków.
  • Punkt 2: Księga główna zapisana jest w pliku BKT.RT. Każde konto finansowe posiada dane dotyczące bilansu otwarcia oraz obrotów poszczególnych miesięcy. Jest dostępna z modułu FK menu Kartoteki do przeglądania lub wykonania potrzebnych wydruków. Jeżeli w systemie są wprowadzone jednostki organizacyjne to księgę główną możemy przeglądać i drukować także z poziomu tych jednostek..
  • punkt 3: Księgi pomocnicze otrzymujemy z innych modułów systemu RT. I tak: z modułu SPRZEDAŻ - Dziennik wystawionych faktur, z modułu MAGAZYN- dziennik dokumentów magazynowych i stan kartotek magazynowych, z modułu ROZRACHUNKI dokładne rozliczenie z poszczególnymi kontrahentami.
Art. 13 ust.4
Księgi rachunkowe powinny być:
  • punkt 1: Wszystkie wydruki są trwale oznaczone nazwą skróconą jednostki, jej NIP-em, nazwą rodzaju Księgi oraz nazwą programu RT wraz z jego wersją. [A]
  • punkt 2: Wyraźnie oznaczone co do roku obrotowego, okresu sprawozdawczego i daty sporządzenia. [A]
  • punkt 3: Wydruki należy przechowywać według zasad przyjętych w jednostce. [U]
    Każdy wydruk ma tytuł oraz podany zakres drukowania oraz posiada w liniach nagłówka następujące dane:
  • 1 linia:
    - po lewej stronie: nazwa jednostki,
    - na środku: symbol Systemu, okres sprawozdawczy (OD .. DO)
    - po prawej stronie: data wykonania wydruku,
  • 2 linia: - po lewej stronie NIP jednostki, - na środku symbol operatora, który wydruk wykonał i rok obrotowy, - po prawej stronie: godzina wykonania wydruku i numer strony. 3, 4 linia oraz następne. [A]
Art. 13 ust. 5:
Wydruki mają w dwóch pierwszych liniach informacje opisane w poprzednim punkcie. Każda strona ma swój numer. Numerowanie stron jest automatyczne i Użytkownik nie ma na nie wpływu. Na końcu wydruku jest dodatkowo informacja "Koniec Wydruku". [A] Wydruki są stronnicowane, na każdej stronie drukowane są pozycje: (jeżeli są niezerowe): do przeniesienia: na końcu obsługiwanej strony, jeżeli będzie kontynuacja wydruku oraz z przeniesienia: na początku następnej strony. [A]
Art. 14 . ust.1
Dziennik jest uporządkowany chronologicznie i umożliwia uzgodnienie jego obrotów z obrotami zestawienia obrotów i sald kont księgi głównej. [A]
Art. 14. ust.2
Zapisy w dzienniku podczas funkcji zamknięcia miesiąca dostają liczbę porządkową dziennika. Wydruk dziennika jest traktowany jak inne wydruki według zasad opisanych w poprzednich punktach. [A]
Art. 14. ust. 3
System przewiduje dzienniki częściowe. Także, w tym przypadku wydrukować można całość dziennika w kolejności chronologicznej. [A]
Art. 14.ust.4
  • W dzienniku ujmowane są tylko zapisy sprawdzone. Dekrety są najpierw wprowadzane do zbiorów operatorskich (bez księgowania ich na konta)> Operator może sprawdzić ich poprawność (istnieje możliwość symulacji księgowania co będzie po faktycznym zaksięgowaniu dekretów). Nim dowody zostaną zaksięgowane System sprawdza, czy są one poprawne pod względem formalnym (bilansowanie, sprawdzanie struktury kont itp.) i jeżeli nie spełniają wymogów, księgowanie nie jest wykonywane. [A]
  • Po zaksięgowaniu dowodów nie są one już dostępne do modyfikacji. Stany kont można korygować za pomocą dowodów korygujących. [A]
  • W czasie księgowania każdy dekret ma nadawany kolejny numer (LP księgowania) widoczny na podglądach i wydrukach dziennika i kartotek. Wszystkie kwoty (dziennika i na kontach) są naliczane od początku roku obrachunkowego do jego zakończenia. Nie ma możliwości np. zmiany stanów konta bez księgowania. [A]
  • Wydruk dziennika jest traktowany jak inne wydruki według zasad opisanych w poprzednich punktach. [A]
  • Dziennik można drukować za dowolny okres. W szczególności może być drukowany za wybrany miesiąc. O tym kiedy należy drukować dziennik decyduje Użytkownik. [U]
Art. 15 ust. 1
Konta księgi głównej zawierają zapisy dotyczące bilansu otwarcia oraz miesięcznych obrotów strony WN i MA . Równocześnie z zapisem w dzienniku zdarzenie zmienia zapis na księdze głównej zgodnie z zasadą podwójnego zapisu.
Art. 15 ust. 2
Zapisy na określonym koncie księgi głównej dokonane są w kolejności chronologicznej.
Art. 16 [Konta ksiąg pomocniczych
Art. 16 ust. 1
Zapisy w księgach pomocniczych ( Środki Trwałe, Sprzedaż, Magazyn ) zawierają zapisy bardziej szczegółowe od zapisów w księdze głównej i muszą być z nią zgodne.
Art. 16 ust. 1
System umożliwia dodatkowo prowadzenie do dwóch naturalnych jednostek miary.
Art. 17 ust. 1
Konta ksiąg pomocniczych można obsługiwać przez program:
  • ST : Środki trwałe oraz wartości niematerialne i prawne oraz dokonywane od nich odpisy amortyzacyjne lub umorzeniowe oraz księgowanie kosztów z tym związanych. Wspomaga prowadzenie inwentaryzacji.
  • Rozrachunki : rozrachunki z kontrahentami, uzgodnienia sald, naliczanie odsetek.
  • PLACE – obliczanie wynagrodzeń pracowników oraz ich rozliczanie z Urzędem Skarbowym i ZUS-em.
  • Sprzedaż – operacje sprzedaży, wystawianie i przechowywanie faktur własnych oraz wprowadzanie faktur VAT RR oraz prowadzenie rejestrów sprzedaży VAT.
  • Magazyn – prowadzenie ewidencji magazynowej poszczególnych asortymentów. Umożliwia prowadzenie inwentaryzacji magazynów.
  • Kasa – wprowadzanie i ewidencja operacji gotówkowych prowadzonych w firmie.
Art. 18 Miesięczne zestawienia
Zestawienia, o których mowa w tym artykule można wykonać w menu Kartoteki modułu RT-FK. [U] [A]


Dostęp do danych

    Aby dane były bezpieczne można zastosować kilka niezależnych od siebie mechanizmów.
  1. Prawa użytkowników do folderów, danych, programów, innych zasobów sieci oraz komputerów.
      Ustawia się to z poziomów systemów operacyjnych Windows i należy do do administratora sieci czyli Użytkownika [U]
  2. Zabezpieczenie dostępu do programów i danych autorstwa PI RolTech jest realizowane za pomocą następujących mechanizmów :
    1. Każda osoba, która pracuje w programie jest musi być zarejestrowana oraz posiadać hasło (nazywana jest dalej Operatorem).
    2. Operatorowi można przypisać określone uprawnienia określające co może robić :
      1. Prawo do pracy w określonym module.
      2. Prawo wykonania danej funkcji menu.
      3. Prawo - zapisu. Operator może mieć jedynie prawo ODCZYTU - wówczas może jedynie korzystać z danych (wykonywać wydruki, przeglądać wprowadzone dane), ale nie ma możliwości ich zmiany.
    3. Operatorowi można przydzielić prawa do określonych zestawów danych - tylko do nich może się zalogować, inne są dla niego niedostępne
  3. Poprawność danych
    1. Obieg dokumentów finansowych, ich numeracje i sposób ich przechowywania ustala Użytkownik. [U]
    2. Operator sytemu nie może zmieniać danych wprowadzonych przez innego operatora. [A]
    3. Programy stosują zabezpieczenia przed wprowadzeniem błędnych danych lub niewłaściwym ich wykorzystaniem; opisane jest to w dokumentacji. [A]
    4. Zasady ewidencji przebiegu przetwarzania danych opisane są w dokumentacji. [A]
  4. Zabezpieczenie danych przed ich utratą w wyniku działań zewnętrznych (np. awaria sprzętu, kradzież komputerów, klęska żywiołowa):
    1. Programy mają specjalne funkcje do wykonywania i odtwarzania kopii danych w każdej chwili. Opis tej czynności znajduje się w dokumentacji programu. [A]
    2. Użytkownik może w zależności od posiadanego sprzętu wykonywać kopie w inny sposób np. za pomocą streamera lub na dyski zewnętrzne. [U]


Podstawowe zasady obsługi programu

    W tym rozdziale przedstawiamy informacje ogólne dotyczące obsługi programu. Użytkownik znajdzie tu informacje na temat poruszania się po menu oraz jego funkcjach. Opisy dotyczą obsługi, której zasady podzielić można na 2 grupy. Pierwsza to wykorzystywanie możliwości (i stosowanie się do ograniczeń) systemu operacyjnego Windows. Druga to zasady stworzone na potrzeby programu. Dla Użytkownika nie ma to praktycznie znaczenia ponieważ obie grupy stosowane są przez cały czas. Ważna jest jednak świadomość, które mają zastosowanie tylko w programie (nie pochodzą z Windows) - nie można ich używać w innym oprogramowaniu (może ono mieć własne zasady).
    Ze szczególną uwagą należy zapoznać się z zasadami szybkiej pracy z klawiaturą. Przy wprowadzaniu dokumentów klawiatura jest wygodniejsza niż myszka. Poniżej przedstawione są zasady obsługi poszczególnych elementów programu.
  • Menu
  • Okna
  • Przyciski
  • Pola danych
  • Przeglądanie danych
  • Drukowanie
  • Klawiatura
  • Korzystanie z Pomocy
  • Aplikacje Windows
  • Współpraca z MS Excel
  • Współpraca w MS Word
  • Współpraca z OpenOffice


Zasady obsługi - Menu

  1. Menu główne
      Menu główne występuje w postaci paska w górnej części ekranu, jego zadaniem jest udostępnienie odpowiednio pogrupowanych funkcji Systemu. Dostęp do funkcji uzyskamy klikając myszką w nazwę odpowiedniej funkcji lub korzystając ze skrótu klawiszowego Lewy Alt+Litera ( wyróżniona podkreśleniem).
  2. Menu niższego poziomu
      Po wybraniu odpowiedniej funkcji rozwija się okienko zawierające listę funkcji związanych z daną funkcją główną. Niektóre elementy tej listy (oznaczone czarnym trójkątem z prawej strony - ►) są podgrupami zawierającymi kolejne listy (w każdym przypadku rozwijając kolejne okna podgrup dochodzimy ostatecznie do zestawu funkcji).
  3. Menu kontekstowe
      Udostępniane jest po kliknięciu prawym klawiszem myszy na wybranym obiekcie. Zawartość menu zależy od powiązanego z nim obiektu.
  4. Poruszanie się po menu
      W obrębie menu poruszamy się przesuwając odpowiednio kursor myszy, lub przy pomocy klawiatury - wykorzystując klawisze kursorów.
  5. Wybór funkcji w menu
      Wybór funkcji następuje po kliknięciu na niej myszą lub podświetleniu za pomocą kursorów i wciśnięciu klawisza Enter.


Okna

  1. Okno główne
      Rozciąga się na cały ekran. Jego elementami są:
    1. Belka tytułowa
        Począwszy od lewej strony ekranu wyświetla następujące informacje:
      1. nazwę przetwarzanego Systemu/ modułu,
      2. nazwę bieżącej firmy,
      3. symbol operatora, który uruchomił moduł.
      4. Oprócz tych danych zawiera zestaw standardowych przycisków okna Windows
        Rozmiar: 1187 bajtów lub Rozmiar: 1149 bajtów
        służących do zwijania okna programu i przenoszenia go na pasek zadań, przełączania okna między trybem pełnoekranowym a pracą w wielu oknach, oraz zakończenia pracy z programem.
    2. Linia głównego menu
        Po wyborze funkcji z menu głównego wyświetlają się funkcje menu niższego rzędu.
        Przesuwając kursor myszy po menu w ostatnim wierszu okna głównego wyświetla się dodatkowy opis funkcji.
        Wybór funkcji odbywa się przy użyciu klawiatury bądź myszy.
    3. Główny obszar roboczy
        Po uruchomieniu i wyświetleniu głównego menu programu początkowo ekran ten wypełniony jest tłem. Uruchomienie dowolnej funkcji programu powoduje otwarcie nowego okna mieszczącego się w obszarze głównego obszaru roboczego. Kolejno otwierane okna nakładają się na siebie, tak jak okna programów w Windows.
  2. Elementy okien
      W oknach niższego rzędu występuje:
    1. Belka z nazwą funkcji i klawiszami zwijania i rozwijania okna.
    2. Pasek narzędzi (przyciski).
        Ułatwia obsługę programu, jego zadaniem jest szybkie udostępnienie wybranej funkcji. Zazwyczaj występuje w górnej części ekranu, poniżej paska menu. Składa się z przycisków opatrzonych ikonami. Można je wywoływać z klawiatury (skróty klawiszowe) lub za pomocą myszy. Naciskając klawisz F9 można aktywować pasek za pomocą klawiatury - aktywowany jest pierwszy przycisk począwszy od lewej strony okna. Klawiszem Tab i Shift+Tab można przechodzić pomiędzy przyciskami. Naciśnięcie ENTER uruchamia funkcję związaną z tym przyciskiem.
        Po nasunięciu kursora myszy na daną ikonę paska narzędzi (bez wciskania przycisku myszy) wyświetla się informacja o funkcji wywoływanej danym przyciskiem. Prócz tego w nawiasach jest podane wywołanie funkcji bezpośrednio z klawiatury bez użycia myszki. Np. Szukanie można wywołać przez jednoczesne naciśnięcie klawisza Ctrl oraz F5.
  3. Okna nadrzędne i podrzędne
      W niektórych funkcjach dla wygody obsługi i korzystania z danych występuje okno nadrzędne i podrzędne, które są ze sobą powiązane. Okno podrzędne wywoływane jest z nadrzędnego i udostępnia szczegóły bieżącej pozycji okna nadrzędnego. W oknie podrzędnym w prawym, górnym rogu występują cztery przyciski umożliwiające skok o jedną pozycję w górę/ dół lub do pierwszej czy ostatniej pozycji . Zmiana pozycji w oknie podrzędnym następuje z równoległą zmianą pozycji w oknie nadrzędnym.
      Np. edycja danych osobowych kolejnego pracownika w oknie Pracownik powoduje również przesunięcie na liście pracowników w oknie Pracownicy.
  4. Zmiana pozycji okna lub rozmiaru
      Po nasunięciu kursora myszy na belkę tytułową i wciśnięciu lewego klawisza myszy można przesuwać okno w obszarze ekranu.
      Można rozszerzać lub zmniejszać rozmiar niektórych okien w programie. Po nasunięciu kursora myszki na brzeg okna pojawia się strzałka pozwalająca na rozciąganie lub zmniejszanie rozmiaru okna. Zmiana rozmiaru jest podyktowana funkcjonalnością, np. zwinięcie okna do minimum powoduje, że informacja nie będzie czytelna.
  5. Zmiana okien
      Można otworzyć wiele okien w różnych funkcjach.
    1. Aktywacja okna - w Windows w danej chwili może być aktywne tylko jedno okno. Wszystkie funkcje wykonywane są tylko na tym oknie.
    2. Okna otwarte wcześniej różnią się od okna ostatnio wywołanego. Ich belka tytułowa ma mniej intensywny kolor.
    3. Przełączenie na inne okno następuje po kliknięciu na jego obszarze.
    4. W przypadku wielu otwartych okien kolejność ich wywołania widoczna jest w funkcji Okna w menu głównym.
  6. Nakładanie się okien
      Okna nakładają się jedno na drugie. Jeśli to nastąpi można przesunąć okno na górze lub sprawdzić kolejność ich wywołania w funkcji Okna.
  7. Edycja danych w oknie
      Jeśli w oknie są edytowane dane to pozostałe okna są wyłączone z edycji. Dopiero po wyborze Zapisz lub Anuluj lub wyjściu z okna przez przycisk X aktywują się pozostałe okna.
  8. Odświeżanie danych w oknie
      Jeżeli na jednym oknie/ funkcji pracuje więcej niż jeden Użytkownik i następuje aktualizacja informacji w oknie to każdy z Użytkowników powinien co pewien czas nacisnąć widoczny na pasku zadań przycisk Odśwież. Następuje wówczas ponowny odczyt danych z baz i wyświetlenie najbardziej aktualnej informacji na ekranie.
      Np. przez funkcję Mój komputer dwóch użytkowników przegląda ten sam folder na serwerze. Jeden z nich tworzy w tym folderze podfolder. Drugi użytkownik zobaczy podfolder dopiero po wykonaniu funkcji Odśwież.


Przyciski

    Przyciski mają za zadanie udostępnienie wybranej funkcji w programie. Przyciski często są pogrupowane - tzw. pasek przycisków zazwyczaj występuje w górnej części ekranu, poniżej paska menu i belki z nazwą funkcji. Składa się z przycisków opatrzonych ikonami. Można je wywoływać z klawiatury (skróty klawiszowe) lub za pomocą myszy. Po nasunięciu kursora myszy na wybraną ikonę paska przycisków (bez wciskania przycisku myszy) wyświetla się informacja o funkcji wywoływanej danym przyciskiem. Prócz tego w nawiasach jest podane wywołanie funkcji bezpośrednio z klawiatury bez użycia myszki. Np. Szukanie można wywołać przez jednoczesne naciśnięcie klawiszy Ctrl+F5.
    Przyciski można podzielić ze względu na realizowane zadania na kilka grup opisanych poniżej.
  1. Pogrupowane w pasek
      Pasek ten występuje pod belką tytułową okna. Są na nim podstawowe paski służące do przeglądania i edycji danych :
    1. Przeglądaj - wyświetlanie danych bez konieczności ich aktualizacji.
    2. Dopisz - dopisanie nowej pozycji.
    3. Edytuj - edycja pozycji.
    4. Usuń - usunięcie pozycji.
    5. Kolejność - zmiana kolejności wyświetlania danych.
    6. Idź do - przejście do zadanej pozycji.
    7. Szukaj - szukanie pozycji o zadanych parametrach.
    8. Drukuj - wykonanie drukowania (dokumentu, listy, zestawienia).
    9. Odśwież - ponowne odczytanie danych (odświeżenie okna).
    10. Pomoc - wywołanie pomocy kontekstowej.
    11. Zamknij - zamknięcie okna (funkcji).
      Na pasku mogą być również inne przyciski do realizacji czynności specyficznych dla danej funkcji.
  2. Wykonanie i anulowanie
      W czasie edycji w lewym rogu pojawia się pasek składający się z 2 przycisków. Jeden z nich to Anuluj - kończy on edycję danych w oknie bez zapisu. Drugi to Zapisz - następuje wówczas zapisanie edytowanej pozycji. Oznaczenie może być inne np. Wykonaj, Drukuj itp. Zawsze chodzi o to samo - potwierdzenie wykonania zadanej czynności.
  3. Specyficzne dla funkcji
      Wykonują operacje specyficzne tylko dla danej funkcji. Zazwyczaj dotyczą one informacji skojarzonej z polem danych. Najczęściej znajdują się za tym polem i mają tylko tekst bez ikony.


Pola danych

    W oknie umieszczone są pola zawierające informacje. Nazywane są również kontrolkami. Zasady ich obsługi są opisane w dokumentacji Windows. W tym punkcie przypominamy jedynie podstawowe zasady dla głównych typów. W praktyce można spotkać jeszcze inne, ale zasady obsługi będą analogiczne.
    Ponieważ zwykle do edycji danych używa się czcionek nieproporcjonalnych, które mają różną szerokość np. 4 liter iiii mają inną szerokość niż 4 WWWW. Najczęściej jest tak, że w edytowanym polu po wpisaniu np. 30 znaków (maksymalna ilość dla tego pola) część pola pozostaje pusta, ale nie można nic tam wprowadzić. Po prostu program może przyjąć tylko określoną ilość znaków. Tego zmienić się nie da.
  1. Siatka

      Służy do wyświetlania danych. Może mieć wiele kolumn, a wierszy tyle ile jest przeglądanych pozycji. Siatkę można przewijać w pionie i ewentualnie w poziomie za pomocą myszy lub klawiatury.
      Klawisze służące do tego celu to :
    1. DOWN (kursor w dół) - następna pozycja.
    2. UP (kursor w górę) - poprzednia pozycja.
    3. PGDN (strona w dół) - przewinięcie w dół o ilość wyświetlanych wierszy.
    4. PGUP (strona w górę) - przewinięcie w górę o ilość wyświetlanych wierszy.
    5. CTRL-PGDN (koniec) - do ostatniej pozycji.
    6. CTRL-PGUP (koniec) - do pierwszej pozycji.
    7. LEFT (kursor w lewo) - poprzednia kolumna.
    8. RIGHT (kursor w prawo) - następna kolumna.
  2. Zakładki

      Każda zakładka składa się z uchwytu i powierzchni do wyświetlania kontrolek. Zestaw zakładek zawiera ich najmniej dwie. Wszystkie zakładki współdzielą powierzchnię wyświetlania, z tym że każda z nich dysponuje własnym zestawem opcji, natomiast na powierzchni wyświetlania są pokazywane pola tylko tej zakładki, która jest aktywna. Po kliknięciu na nieaktywną zakładkę następuje najpierw dezaktywacja aktywnej, a następnie uaktywnienie nowo wybranej zakładki.
  3. Przycisk

      Wykonuje wskazaną czynność. Standardowo przycisk reaguje jedynie na pojedyncze naciśnięcie lewego przycisku myszy. Obsługa ze strony użytkownika polega na nasunięciu nań kursorem myszy oraz wciśnięciu lewego przycisku myszy. Po jego naciśnięciu przycisk chwilowo zmienia wygląd na wciśnięty, a następnie po puszczeniu przycisku myszy wygląd przycisku przywracany jest na wypukły i w tym momencie generowane jest zdarzenie wciśnięcia przycisku. Jeżeli w tekście przycisku jest litera z podkreśleniem to można go uaktywnić za pomocą kombinacji klawiszy lewy ALT + podkreślona litera.
  4. Pole tekstowe

      Pole edycyjne służy do edycji tekstu. Ma ograniczoną długość oraz format. Zależnie od tych właściwości można wprowadzać czasem np. tylko cyfry, czasem program sam zamienia litery na duże. Pole może być wielowierszowe. W polu edycyjnym można także wykonywać wszelkie czynności edycyjne - kopiowanie, wycinanie i wklejanie tekstu.
  5. Lista rozwijalna

      Jest wielkości jednej linijki tekstu z obramowaniem. Po naciśnięciu na tym polu lewym klawiszem myszy rozwija się lista opcji do wyboru (jest zwykle wyposażona w pasek przesuwania, jeśli pozycji jest więcej, niż przewidzianego na nie miejsca do pokazania). Kiedy lista tych linijek jest pokazana, można wtedy wybrać jedną z interesujących pozycji poprzez kliknięcie na nią lewym klawiszem myszy. Po dokonaniu tego wyboru, lista rozwijalna wraca znów do "stanu spoczynku". Możemy również kliknąć gdzieś poza obszarem rozwiniętej listy lub nacisnąć klawisz Esc i wtedy lista zostanie zwinięta, a aktualna jej wartość się nie zmieni.
  6. Lista
  7. Pokrętło

      Jest to zasadniczo pole tekstowe przeznaczone do obsługi liczb i tak samo się je obsługuje. Dodatkowo na końcu pola są kursory, którymi można zmieniać wartość w polu o zadaną wielkość. Pole może mieć określone minimalną i maksymalną wartość - po ich przekroczeniu nie można opuścić pola.
  8. Opcje wyboru.

      Może się składać z 2 lub więcej elementów, z których każdy może mieć opis. Można wybrać tylko jedną opcję :
    1. naciskając lewy przycisk myszy na wybranej opcji lub
    2. przechodząc za pomocą kursorów do zadanej opcji i naciskając klawisz Spacji.
  9. Zaznaczenie

      Jest to przełącznik dwustanowy - kliknięcie lewym przyciskiem myszy lub naciśnięcie spacji zmienia stan. Przełącznik jest włączony kiedy ma zaznaczenie w kwadracie.
  10. Przechodzenie pomiędzy polami
      Pola danych umieszczone są w oknach. Jeżeli jesteśmy w trybie edycji, to w danej chwili aktywne może być tylko jedno pole. Pole można aktywować na kilka sposobów :
    1. Klikając na wybrane pole myszą (lewy lub prawy przycisk).
    2. Przechodząc kolejno pomiędzy polami za pomocą klawiatury TAB - następne pole, SHIFT-TAB - poprzednie pole. Kolejność ta jest ustalana przez autorów programu i nie może być zmieniana przez Użytkownika.
  11. Zapisywanie danych i anulowanie wprowadzonych zmian.
      Kiedy wprowadzimy dane i sprawdzimy że są poprawne możemy je :
    1. Zapisać za pomocą :
      1. Przycisku Zapisz umieszczonego zazwyczaj w lewym dolnym rogu okna.
      2. Naciśnięcia podkreślonego znaku (trzymając wciśnięty lewy ALT) z napisu na przycisku. Np. Dla Zapisz jest to ALT+Z.
      3. Klawiszy CTRL+END.
    2. Anulować wprowadzone zmiany :
      1. Przyciskiem Anuluj umieszczonym zazwyczaj w lewym dolnym rogu okna.
      2. Naciśnięciem podkreślonego znaku (trzymając wciśnięty lewy ALT) z napisu na przycisku. Np. Dla Anuluj jest to ALT+A.
      3. Klawiszem ESC.


Przeglądanie i edycja danych

  1. Przeglądanie danych
      Przeglądania danych służy do prezentowania i przetwarzania większej ilości informacji tego samego rodzaju (np. kontrahenci, dokumenty. W oknach tego typu dane prezentowane są w postaci tabelarycznej, przy czym możliwe jest przemieszczanie się pomiędzy poszczególnymi wierszami, wyszukiwanie wierszy spełniających określone warunki oraz wykonywanie operacji na jednym lub wielu wierszach. Możliwe jest również dodawanie wierszy bądź modyfikowanie zawartych w nich danych, jednak z reguły odbywa się to poprzez wskazanie wiersza i wywołanie dla niego odpowiedniego okna przeznaczonego do edycji.
      Najprostsze okno przeglądania składa się z tabeli (siatki danych), w której prezentowane są dane z możliwością szczegółowego przeglądania kolumn wiersza oraz czasem podsumowanie tabeli. Nad siatką zazwyczaj jest pasek przycisków służący do realizacji różnych operacji wykonywanych na wyświetlanych pozycjach.
  2. Kolejność
      W zależności od potrzeby lista (kartoteka, rejestr) może być uporządkowana alfabetycznie lub numerycznie według różnych kluczy sortowania. Nazwa kolumny wyznaczającej aktualną kolejność danych jest wyróżniona podkreśloną lub prostą czcionką - kolumny mające nagłówek pisany kursywą nie może być wskazana jako ta, według której ustalana jest kolejność. Zmiany sposobu uporządkowania danych na liście można dokonać:
    1. klikając na nazwie kolumny, według której ma być sortowana lista,
    2. naciskając klawisz F7,
    3. za pomocą przycisku Kolejność na pasku przycisków.
  3. Szukanie
    1. Szybkie = Idź do
        Jest to szukanie p pojedynczej pozycjii w kartotece lub na dowolnej liście np. liście kont finansowych, o ile znamy początkową część wyszukiwanej nazwy / symbolu. Wyszukiwanie działa zawsze według kolumny wyznaczającej aktualną kolejność. Taka kolumna wyróżniona jest wytłuszczonym lub podkreślonym nagłówkiem. Naciśnięcie dowolnej litery lub cyfry, powoduje wpisanie jej do okienka wyszukiwania wyświetlonego automatycznie w centralnej części listy. Można wówczas uzupełnić szukany element. Aby nastąpiło wyszukiwanie należy nacisnąć klawisz Enter lub kliknąć na przycisku Idź do... Lista jest przeszukiwana z góry na dół, a podświetlenie ustawiane jest na pierwszej pozycji, której nazwa pokrywa się z tekstem wprowadzonym do okienka wyszukiwania. Jeżeli wyszukiwana sekwencja znaków nie zostanie znaleziona, to podświetlenie ustawia się na pozycji "większej" niż szukana. Przy wyszukiwaniu małe i duże litery nie są rozróżniane. Oznacza to, że niezależnie od tego czy piszemy małymi czy dużymi literami, nazwa (jeśli tylko istnieje) zostanie znaleziona. Funkcję szybkiego wyszukiwania można uruchomić na kilka sposobów. Oprócz wpisywania szukanego ciągu znaków można nacisnąć klawisz F5 lub kliknąć przycisk Idź do ... na pasku przycisków, a następnie wpisać szukany ciąg znaków.
    2. Zaawansowane
        Z kolei funkcja Szukaj pozwala na bardziej zaawansowane wyszukiwanie na liście. Jest dostępna jest po wybraniu klawisza Ctrl+F5 lub za pomocą przycisku Szukaj. Funkcja :
      1. wyszukuje pozycje po dowolnym fragmencie poszukiwanej nazwy, który nie musi być początkiem nazwy,
      2. wyszukuje pozycje w oparciu o wartości przechowywane w różnych kolumnach. Np. wyszukanie kontrahentów z miejscowości Opole lub numerze NIP 754-00-24.
        Ponowny wybór funkcji Szukaj wyświetla ostatni wynik wyszukiwania.
  4. Edycja danych
      Rozumiemy przez to każdą operację zmieniającą stan danych (dopisanie,aktualizacja, usunięcie itp). Po wejściu w tryb edycji i wprowadzeniu danych należy je zapisać. Nim się to stanie program sprawdzi poprawność tych danych. Jeżeli są niepoprawne program zgłosi to i będzie czekał na poprawę. Obsługa pól danych jest opisana w punkcie Pola danych.
  5. Powiązania pomiędzy oknami
      Zarówno przy przeglądaniu jak i edycji danych mamy zazwyczaj do czynienia z zestawem powiązanych ze sobą okien. Można je załączać (pokazywać) lub wyłączać (zamykać). Zwykle wykonuje się to za pomocą przycisków Przeglądaj i Zamknij. Relacja pomiędzy oknami nadrzędnymi i podrzędnymi została opisana w punkcie Obsługa - Okna. Przy wejściu w tryb edycji pozostałe okna oprócz tego, w którym dokonujemy edycji, zostają zablokowane.


Drukowanie

    W programie można wykonywać wydruki w 4 postaciach : graficznym , tekstowym, do arkusza Excel'a, do pliku XML. Są od tej reguły wyjątki - to dokumenty np. faktury, kasowe, magazynowe itp. One mogą być drukowane w postaci graficznej lub tekstowej. Parametry wszystkich wykonywanych wydruków są ustawiane w oknie sterującym wydrukiem. W nim dokonuje się wyboru drukarki, postaci oraz innych ustawień parametrów drukowania.
  1. Wykonanie wydruku
  2. Tryb graficzny
      Służy do drukowania w trybie graficznym na drukarkach laserowych i atramentowych. Można też drukować na drukarkach igłowych w trybie graficznym, ale jest to mało efektywne. Należy :
    1. Wybrać zakładkę Drukarka.
    2. Wskazać drukarkę w polu Nazwa. Jeżeli jest to drukarka laserowa lub atramentowa program sam ustawi postać na Graficzna, w przeciwnym razie trzeba to zrobić samemu. Dla drukarek mających możliwość drukowania dwustronnego (dupleks) można ustawić jego parametry w polu Drukowanie dwustronne. Pole Orientacja umożliwia wymuszenie orientacji (portret/pejzaż) - program sam ustawia ten parametr (zazwyczaj zależy to od szerokości wydruku).
  3. Tryb tekstowy
      Służy do drukowania w trybie tekstowym na drukarkach igłowych. Można też drukować na drukarkach laserowych i atramentowych w trybie tekstowym, ale wtedy drukarka musi mieć taką możliwość. Należy :
    1. Wybrać zakładkę Drukarka.
    2. Wskazać drukarkę w polu Nazwa. Jeżeli jest to drukarka igłowa program sam ustawi postać na Tekstowa, w przeciwnym razie trzeba to zrobić samemu.
      Dla trybu tekstowego można również wydruk wykonać do pliku. W tym celu trzeba wybrać zakładkę Plik i wpisać jego nazwę w polu Do pliku.
  4. Postać arkusza Excel'a
      O ile jest zainstalowany program Excel można wykonywać wydruki w postaci arkuszy (skoroszytów). Należy wybrać zakładkę Arkusz Excel'a i podać nazwę pliku w polu Do pliku.
  5. Postać pliku XML obsługiwanego przez OpenOffice lub Excel 2003 ( i wyzsze wersje)
      Należy wybrać zakładkę XML i podać nazwę pliku w polu Do pliku. Do wykonania wydruku nie jest wymagania instalacja OpenOffice. Instalacja jest konieczna jeżeli chcemy przeglądać takie wydruki.
  6. Pozostałe parametry
      Dodatkowo dla trybu graficznego i tekstowego można ustawić następujące parametry :
    1. Tylko drukarki lokalne - program umożliwia wybór tylko drukarek lokalnych, czyli fizycznie podłączonych do tego komputera.
    2. Przycisk Odśwież - ponownie pobiera listę drukarek.
    3. Strony od do - drukuje tylko wybrany przedział stron.
    4. Ilość kopii - ile razy wydrukować wybrane zestawienie.
    5. Przycisk Właściwości drukarki - wywołuje okno systemu Windows do obsługi właściwości bieżącej drukarki.
    6. Przycisk Właściwości wydruku - wywołuje okno domyślnych ustawień drukowania.
  7. Domyślne parametry wydruku
      Każdy Użytkownik ma swoje domyślne parametry drukowania. Ustawia się je w funkcji Administracja->Użytkownicy zakładka Drukowanie.
  8. Wydruki wykonane na dysk
      Wydruk możemy przechowywać w przez nas nazwanym pliku na dysku z wyjątkiem wydruku w trybie graficznym. Możemy później wywołać funkcję zarządzającą Inne->Wydruki wykonane na dysk (można to też zrobić za pomocą klawisza F4) i zrobić z tym plikiem co się nam podoba : przeglądać, drukować, usunąć, skopiować itp.


Klawiatura

    Posługiwanie się klawiaturą jest zazwyczaj bardziej efektywne niż używanie myszy. Klawisze lub ich kombinacje nazywane są skrótami klawiaturowymi. Ze względu na to gdzie ich obsługa została zdefiniowana można je podzielić na 2 grupy opisane poniżej.
  1. Standardowe klawisze Windows
      Sam Windows ma zdefiniowanych wiele skrótów klawiaturowych. Poniżej jest podana lista tych najczęściej używanych. Jeżeli zajdzie potrzeba należy poszukać informacji w dokumentacji Windows.
    1. Praca z myszka
    2. Menu i okna
      1. Alt + podkreślona litera - otwiera wybrane menu w menu głównym programu,
      2. Alt + Tab - szybkie przełączanie się między aktywnymi programami,
      3. Alt + F4 - zamknięcie okna, zakończenie pracy programu,
      4. Ctrl + Esc - zastępuje naciśnięcie przycisku Start.
    3. Pola danych
      1. Tab - przejście do kolejnego pola przy edycji danych lub skok do kolejnej kolumny. Na pasku narzędzi umożliwia przejście do kolejnego przycisku.
      2. Shift + Tab - powrót do poprzedniego pola przy edycji danych lub skok do poprzedniej kolumny. Na pasku narzędzi powoduje przejście do poprzedniego przycisku.
    4. Schowek
      1. Ctrl + C - operacja Kopiuj,
      2. Ctrl + V - operacja Wklej,
      3. Ctrl + X - operacja Wytnij,
  2. Klawisze definiowane w programie
    1. Okna i kartoteki danych
      1. Esc - zamknięcie okna.
      2. Kursor w górę - przejście do poprzedniego pola/ wiersza.
      3. Kursor w dół - przejście do następnego pola/ wiersza.
      4. PageUp - przewinięcie listy o jeden ekran w górę.
      5. PageDown - przewinięcie listy o jeden ekran w dół.
    2. Edycja danych
      1. Insert - dodanie nowej pozycji (pracownika, składnika płacowego, itd).
      2. Enter
      3. Delete - kasowanie zaznaczonej pozycji (składnika płacowego, definicji wypłaty).
      4. ESC
      5. Ctrl + End - wprowadzenie wybranej pozycji (pracownika, składnika) do pola.
      6. F12 - wywołanie listy podpowiedzi przy edycji pola wyróżnionego zielonym tłem.
      7. F5 - Idź do .. - szukanie po części nazwy/symbolu w aktywnej kolumnie. Duże i małe litery nie są rozróżnialne.
      8. F5 - szukanie po części nazwy/symbolu w aktywnej kolumnie. Duże i małe litery nie są rozróżnialne.
      9. Ctrl + F5 - wyszukiwanie zaawansowane.
      10. F6 - przejście do drukowania.
      11. F7 - zmiana kolejności danych.
      12. F9 - aktywuje przyciski na pasku narzędzi
    3. Funkcje programów wywoływane w każdej chwili
      1. F1 - pomoc kontekstowa dla bieżącego okna dialogowego.
      2. F3 - kalkulator Windows.
      3. F4 - wydruki na dysku.
      4. Alt + F3 - wywołanie kalkulatora taśmowego.
    4. Aplikacje zewnętrzne
      1. Ctrl + F2 - wywołanie Excela.
      2. Alt + F2 - wywołanie OpenOffice.
      3. Shift + F2 - wywołanie Microsoft Word.

Copyright © 2016 PI Rol-Tech


Korzystanie z Pomocy

    Niniejsza Pomoc jest to standardowy plik typu CHM. Zasady obsługi są takie same jak innych dokumentacji dla programów Windows.
  1. Wywołanie
      Pomoc można wywołać z programu na kilka sposobów :
    1. Z menu głównego, funkcja Pomoc->Tematy Pomocy - wówczas wywoływany jest spis treści i można wybrać temat .
    2. Jako pomoc kontekstowa - określenie to stosowane jest do wywołania Pomocy z konkretnej funkcji, kiedy od razu zgłasza się punkt, który jej dotyczy. Można to zrobić na dwa sposoby będąc w aktywnym oknie :
      1. Naciskając przycisk Pomoc - jest umieszczony na pasku przycisków z prawej strony okna lub w prawym dolnym rogu okna.
      2. Za pomocą klawisza F1.
  2. Zasady wyszukiwania informacji
      Pomoc składa się z 2 rodzajów punktów : rozdziałów (oznaczonych ikoną folderu) i kartek, które zawierają opisy (zaznaczonych ikoną kartki). Foldery można rozwijać i zwijać naciskając lewym przyciskiem myszy na znak + (plus) będący przed ikoną folderu. Klikając na wybranym punkcie powodujemy wyświetlenie jego zawartości w prawym oknie.
      Nad spisem treści są 4 zakładki :
    1. Spis treści - Spis wszystkich punktów dokumentacji.
    2. Indeks - Wybranie tej zakładki pozwala na wyszukanie pozycji dotyczących wybranego tematu, z listy która znajduje się poniżej. Jeżeli z tematami skojarzonych jest kilka punktów to pojawi się małe dodatkowe okno gdzie należy wskazać punkt dokumentacji i nacisnąć Wyświetl.
    3. Wyszukaj - Po wpisaniu wyrażenia w pole Wpisz słowo kluczowe, jakie chcesz znaleźć i naciśnięciu Lista tematów pojawią się punkty Pomocy, które zawierają to wyrażenie. Teraz można przyciskiem Wyświetl lub podwójnym kliknięciem myszy wyświetlić w prawym oknie wskazany punkt.
    4. Ulubione - można dodać bieżący temat do listy ulubionych. Wtedy będzie się on pokazywać na tej liście.
  3. Drukowanie
      Wybrane tematy (lub całość) Pomocy można wydrukować za pomocą przycisku Drukuj w oknie Pomocy. Ale ... ??? Nim coś wydrukujesz zastanów się, CZY JEST TO NAPRAWDĘ KONIECZNE. CHROŃMY LASY !


Aplikacje Windows

    Jest to ułatwienie wywołania niektórych programów stanowiących część Windows. Nie trzeba wtedy przechodzić do Pulpitu lub Menu Start->Programy. Od momentu uruchomienia Excel'a programy obsługuje się, jakby zostały wywołane normalnie.
  1. Notatnik
      Można go wywołać wykonać z programu na 2 sposoby :
    1. Z menu głównego, funkcja Inne->Notatnik.
    2. W każdej chwili za pomocą klawiszy CTRL+F3.
  2. Kalkulator Windows
      Można go wywołać z programu na 2 sposoby :
    1. Z menu głównego, funkcja Inne->Kalkulator Windows.
    2. W każdej chwili za pomocą klawisza F3.


Współpraca z MS Excel

  1. Informacje podstawowe
      Podstawowym warunkiem jest to, aby program Excel był zainstalowany na komputerze, na którym pracuje Użytkownik. Minimalna wersja to '97. Obydwa programy instaluje się oddzielnie, w dowolnej kolejności. Od momentu uruchomienia Excel'a obsługuje się, jakby został wywołany z pulpitu.
  2. Wywołanie Excel'a
      Można wykonać z programu na kilka sposobów :
    1. Z menu głównego, funkcja Inne->Microsoft Excel.
    2. W każdej chwili za pomocą klawiszy CTRL+F2.
    3. Przy drukowaniu, kiedy wybrana została opcja drukowania do arkusza Excel'a przyciskiem Przeglądaj. Wtedy wykonywany wydruk zostanie otworzony przez Excel'a do przeglądania.
    4. Kiedy w funkcji Wydruki na dysku uruchomione zostało przeglądanie lub drukowanie wydruku wykonanego na dysk.
  3. Obsługa wydruków wykonanych do Excel'a
      Wydruku do pliku w postaci arkusza (skoroszytu) Excel'a jest obsługiwany według następujących zasad :
    1. Uruchamiany jest Excel' w sposób niejawny - nie widać go na ekranie komputera.
    2. Każda operacja jest wykonywana przez Excel - program przekazuje rozkaz do Excel'a, który go realizuje.
    3. Ponieważ wypełnienie komórek arkusza jest realizowane przez Excel to może to potrwać od kilkunastu sekund do kilku minut. Zależne jest to od prędkości komputera oraz wielkości wykonywanego wydruku.
    4. Plik jest tworzony w takiej wersji Excel'a, w jakiej został on zainstalowany na komputerze. Jest to ważne przy przekazywaniu plików innym osobom. Mogą one mieć niższą wersję Excel'a i wtedy nie będą mogły otworzyć tego pliku. Do wydruków stosowane są jedynie podstawowe formuły, które są akceptowane przez Excel począwszy od wersji '97. Dlatego przy przekazywaniu skoroszytów najlepiej jest zapisać plik w wersji '97.
    5. Nie ma możliwości drukowania do arkusza jeśli Excel nie jest zainstalowany na komputerze.
  4. Praca w trybie terminalowym
      Jeżeli Użytkownik pracuje w trybie terminalowym, to na serwerze musi zostać zainstalowany Excel. Nie jest to jednak zwykła licencja - realizowana jest na specjalnych zasadach. W celu otrzymania bliższych informacji należy skontaktować się z przedstawicielem firmy Microsoft - najlepiej z tym, u którego kupiono system Windows. Drugim problemem jest to, że arkusze (pliki) są tworzone też na serwerze. Trzeba uruchomić i skonfigurować serwer FTP, aby pliki te można było przesyłać z serwera do swojego komputera.


Współpraca z MS Word

  1. Informacje podstawowe
      Podstawowym warunkiem jest to, aby program Word był zainstalowany na komputerze, na którym pracuje Użytkownik. Minimalna wersja to '97. Obydwa programy instaluje się oddzielnie, w dowolnej kolejności. Program Word mozna jedynie wywołać z programu Płace. Od momentu uruchomienia Word'a obsługuje się tak, jakby został wywołany z pulpitu.
  2. Wywołanie Word'a
      Można to wykonać z programu na 2 sposoby :
    1. Z menu głównego, funkcja Inne->Microsoft Word.
    2. W każdej chwili za pomocą klawiszy SHIFT+F2.
  3. Praca w trybie terminalowym
      Jeżeli Użytkownik pracuje w trybie terminalowym to na serwerze musi zostać zainstalowany Word. Nie jest to jednak zwykła licencja - realizowana jest na specjalnych zasadach. W celu otrzymania bliższych informacji należy skontaktować się z przedstawicielem firmy Microsoft - najlepiej z tym, u którego kupiono system Windows. Drugim problemem jest to, że pliki są tworzone też na serwerze. Trzeba uruchomić i skonfigurować serwer FTP, aby pliki te można było przesyłać z serwera do swojego komputera.


Współpraca z OpenOffice

  1. Informacje podstawowe
      Podstawowym warunkiem jest to, aby program OpenOffice w wersji minimalnej 3.0 był zainstalowany na komputerze, na którym pracuje Użytkownik. Obydwa programy instaluje się oddzielnie, w dowolnej kolejności. Współpraca dotyczy jedynie programu CALC.EXE, który obsługuje arkusze (odpowiednik Excel'a). Od momentu uruchomienia OpenOffice obsługuje się, jakby został wywołany z pulpitu.
  2. Wywołanie OpenOffice
      Można to wykonać z programu na kilka sposobów :
    1. Z menu głównego, funkcja Inne->OpenOffice [ arkusz kalkulacyjny ].
    2. W każdej chwili za pomocą klawiszy ALT+F2.
    3. Przy drukowaniu, kiedy wybrana została opcja drukowania do pliku XML przyciskiem Przeglądaj. Wtedy wykonywany wydruk zostanie otworzony przez OpenOffice do przeglądania.
    4. Kiedy w funkcji Wydruki na dysku uruchomione zostało przeglądanie lub drukowanie wydruku wykonanego na dysk.
  3. Obsługa wydruków wykonanych do OpenOffice
      Wydruk wykonany do pliku w postaci arkusza (skoroszytu) OpenOffice jest obsługiwany według następujących zasad :
    1. Wydrukiem jest plik XML w standardzie Excel 2003.
    2. W momencie wykonywania wydruku nie ma konieczności aby OpenOffice był zainstalowany - konieczny jest jednak do jego przeglądania.
    3. Wykonanie wydruku jest stosunkowo szybkie (inaczej niż do arkusza Excel'a). Zależne jest to od prędkości komputera oraz wielkości wykonywanego wydruku. Dłuższe jest tylko pierwsze uruchomienie OpenOffic'a - każde następne jest już szybsze. Najdłużej może trwać otwarcie pliku - jest to plik XLS (czyli tekstowy) i jego interpretacja może chwilę potrwać.
    4. Plik jest akceptowany w Excel'u w wersji 2003 lub wyższej. Przy otwieraniu pliku w Excel' u trzeba jedynie wybrać Pliki typu : XML.
  4. Praca w trybie terminalowym
      Jeżeli Użytkownik pracuje w trybie terminalowym, to jedynym problemem jest to, że arkusze (pliki XML) są tworzone na serwerze. Trzeba uruchomić i skonfigurować serwer FTP, aby pliki te można było przesyłać z serwera do swojego komputera.


Kopie danych

Zabezpieczenie danych

Zgodnie z Ustawą o rachunkowości konieczne jest okresowe zabezpieczanie danych tak, aby nie uległy one zniszczeniu. Jedna z metod zabezpieczania baz jest drukowanie zestawień, których forma została określona w Ustawie. Jednakże dodatkowo należy zapewnić integralność baz danych dla nośników magnetycznych, tzn. dysków. Dlatego też należy okresowo wykonywać kopie na dyskietki, aby np. gdy zepsuje się komputer bądź dysk dane nie zostały utracone. W systemie funkcja kopiowania została rozwiązana następująco: kopiowany jest stan danych na chwilę, w której kopiowanie jest wykonywane. Oznacza to, że wszystkie zbiory, zawierające dane (nie dotyczy to zbiorów indeksowych i programów, które nigdy nie są kopiowane) są kompresowane do jednego zbioru, który zostaje następnie zapisany do archiwum. W praktyce jednak rzadko zajdzie konieczność odtwarzania danych z kopii zapasowych. Wynika to z faktu, że istnieje możliwość wycofania się niemal z każdej operacji zmieniającej stan danych, którą uznaliśmy za nieprawidłową. Odtwarzanie danych z kopii zapasowych stosuje się tylko w sytuacjach awaryjnych. To znaczy jeżeli nastąpi uszkodzenie dysku komputera bądź też w razie potrzeby przeniesienia danych na inny dysk. Kopie należy więc wykonywać zawsze po wprowadzeniu nowych danych (jeżeli pracujemy codziennie - każdego dnia). Ponieważ odtwarzanie powoduje przywrócenie stanu danych z momentu, kiedy kopia została wykonana, dlatego należy wykonywać tą operację z dużą ostrożnością.

    W tym rozdziale opisane są funkcje służące do obsługi kopii danych
  • Wykonanie - Wykonanie kopii danych w oparciu o zdefiniowane projekty kopiowania.
  • Odtworzenie - Odtworzenie kopii danych.
  • Projekty kopiowania - Określenie sposobów wykonania kopii danych na dostępne nośniki (CD, archiwum na HD).
  • Identyfikacja kopii - Odczytanie informacji o kopii bez jej odtworzenia.


Menu - Wykonanie kopii danych

    Funkcja wykonuje kopię danych wybranej firmy według wcześniej określonego projektu kopiowania. Kopiowane są również bazy startowe (konfiguracyjne) - definicje firm, zestawów, operatorów i ich uprawnienia. Można je odtworzyć załączając odpowiednią opcję przy odtwarzaniu.
  1. Czynności przed rozpoczęciem kopiowania.
      Zanim rozpocznie się kopiowanie danych należy sprawdzić, czy ktoś inny pracuje na tym zestawie danych. Trzeba bowiem pamiętać, że kopia musi być kompletna - wykonana na określony moment i nie jest możliwe zapamiętanie stanu danych, które ciągle się zmieniają. Jeżeli ktoś będzie pracował to program i tak nie wykona kopii. Drugą czynnością jest przygotowanie dodatkowego nośnika, np. CD lub pen-drive'a, do zapisania aktualnie wykonywanej kopii na dodatkowym nośniku danych.
  2. Zakres kopiowania
      Najpierw należy podać zakres :
    1. Projekt - symbol projektu, według którego ma zostać wykonane kopiowanie.
    2. Firma - symbol firmy, której dane chcemy zabezpieczyć.
    3. Wprowadzić opis kopii. Np. jaki jest stan danych może opis co zawierają. Są to istotne informacje, które mogą się przydać, kiedy po jakimś czasie konieczna będzie identyfikacja kopii. Ręczne opisanie pisakiem CD lub inny sposób nie jest tak pewny jak załączony opis - znajdzie się on wewnątrz pliku stanowiącego kopię.
    4. Kopiuj do - kopia może być dodatkowo skopiować do wskazanego folderu. Domyślnie jest wstawiany folder określony w projekcie kopii. Folder ten można zmienić. Folder ten musi istnieć i być dostępny dla bieżącego Użytkownika Windows. Jeżeli zostanie zaznaczona opcja Kopiuj z folderem RRRR_MM_DD (data wykonania) to kopia zostanie umieszczona w takim podfolderze (w stosunku do wskazanego folderu). Domyślnie ten parametr jest ustawiany zgodnie z projektem.
    5. Można też wysłać kopię bezpośrednio na serwer FTP PI Rol-Tech. Jest to wygodne jeśli taka potrzeba zachodzi - nie trzeba kopii wstawiać jako załącznik do poczty. Program wie jak i gdzie ją wysłać wysłać - zostanie zapisana na serwerze FTP Rol-Tech'u a dostęp do niej będą miały jedynie osoby uprawnione. Po jej odebraniu z serwera przez pracownika PI Rol-Tech zostanie ona z niego usunięta.
    6. Dodatkowo kopię można wysłać na wybrany e-mail. Jest to możliwe, kiedy domyślną pocztą są programu Microsoftu np. Outlook Express. Wówczas po zakończeniu wykonywania kopii wywołany zostanie program pocztowy z nową wiadomością, zaś aktualnie wykonywana kopia zostanie dołączona jako załącznik.
  3. Etapy wykonania kopii
    1. Kompresja - Aby dane miały mniejszą objętość zostają sprężone. Zazwyczaj plik wynikowy (archiwum) jest mniejszy kilkanaście razy od danych. Używane do tego są mechanizmy wbudowane w Windows - FCI i FDI, które obsługują pliki typu CAB. Skompresowany plik zawierający dane zostanie umieszczony w folderze zgodnym z ustaleniami wybranego projektu kopiowania. Przed rozpoczęciem kompresji program sprawdza, czy nikt nie jest zalogowany do tego zestawu danych (firmy). Jeżeli ktoś pracuje zostanie wyświetlony komunikat i kopiowanie zostanie przerwane.
    2. Przesłanie kopii do wskazanej lokalizacji - Jeżeli został wskazany folder dla opcji Dodatkowo archiwum kopiuj do folderu plik archiwum zostanie tam skopiowany. Jeśli folderem tym jest pen-drive to należy upewnić się przed rozpoczęciem kopiowania, że symbol dysku przydzielony dla pen-drive jest taki jak zadeklarowany w projekcie.
    3. Zakończenie kopiowania - na koniec kopiowania program może wykonać akcję zadaną w projekcie kopiowania.
  4. Kopiowanie na inne nośniki
    1. Kopiowanie na dysk CD-ROM ( lub odpowiednio DVD-ROM )
      1. Wkładamy pusty zapisywalny dysk CD do nagrywarki dysków CD.
      2. Klikamy przycisk Start, a następnie polecenie "Mój komputer".
        Innym sposobem wywołania jest trzymając klawisz "WINDOWS" naciskamy "E" na klawiaturze.
      3. Wybieramy plik, który w kroku C zrobiliśmy lub cały folder _ARCHIWUM, albo tylko jego część dotyczącą wybranej firmy ( podkatalog _ARCHIWUM ) które chcemy skopiować na dysk CD.
        Aby zaznaczyć wiele plików, trzymamy klawisz CTRL, klikając odpowiednie pliki. Następnie w obszarze Zadania plików i folderów klikamy łącze Kopiuj ten plik, Kopiuj ten folder lub Kopiuj zaznaczone elementy.
      4. W oknie dialogowym Kopiowanie elementów klikamy stację dysków z możliwością nagrywania dysków CD, a następnie klikamy przycisk Kopiuj.
      5. W oknie Mój komputer dwukrotnie klikamy na stację dysków do nagrywania dysków CD.
        W systemie Windows zostanie wyświetlony obszar tymczasowy, w którym są umieszczane pliki przed skopiowaniem. Sprawdzamy, czy pliki i foldery, które zamierzamy skopiować na dysk CD, są wyświetlane w obszarze Pliki gotowe do zapisania na dysku CD.
      6. W obszarze Zapisywanie na dysku CD klikamy łącze Zapisz te pliki na dysku CD.
        W systemie Windows zostanie wyświetlony Kreator zapisywania na dysku CD.
        Postępujemy zgodnie z instrukcjami tego kreatora.
      7. Po skopiowaniu na dysk CD możemy przejrzeć zawartość tego dysku, aby potwierdzić skopiowanie plików.
    2. Kopiowanie na zewnętrzny dysk wymienny lub pamięć typu FLASH
      1. Podłączamy dysk zewnętrzny lub pamięć typu FLASH do złącza USB.
        Na dysku tym możemy utworzyć katalog (np. Kopia_2012_08_31) w którym umieścimy nasze kopiowanie.
      2. Wykonujemy punkty D.1.b i D.1.c.
      3. W oknie dialogowym klikamy napęd z dyskiem zewnętrznym z pkt.D.2.1. i ewentualnie wybrany na nim katalog, a następnie klikamy przycisk Wklej.

Patrz także

Kopie danych (kopie bezpieczeństwa) | Projekty kopiowania | Odtworzenie kopii danych | Identyfikacja kopii


Menu - Odtworzenie kopii danych

    Funkcja odtwarza kopię danych wybranej firmy wykonanej za pomocą funkcji Wykonanie kopii danych
  1. Czynności przed rozpoczęciem odtwarzania.
      Zanim rozpocznie się odtwarzanie danych należy sprawdzić, czy ktoś inny pracuje na tym zestawie danych. Trzeba bowiem pamiętać, że kopia musi być odtworzona w całości - została wykonana na określony moment i nie jest możliwe połączenie części danych aktualnie edytowanych z danymi zapisanymi z kopii np. sprzed miesiąca. Jeżeli ktoś będzie pracował to program i tak nie odtworzy kopii. Jeżeli chcemy odtworzyć również bazy startowe (konfiguracyjne) to wszyscy inni Użytkownicy muszą opuścić programy niezależnie od tego, w jakim zestawie danych pracują.
  2. Zakres kopiowania
      Najpierw należy podać zakres :
    1. Firma - symbol firmy, której dane chcemy odtworzyć.
    2. Kopia zostanie odtworzona do folderu - Domyślnie wyświetla się lokalizacja wybranego zestawu danych. Przyciskiem 'Zmień folder docelowy' możemy wskazać inne miejsce odtworzenia danych ( np. jeśli nastąpiła rekonfiguracja, tworzona jest firma testowa, itd.).
    3. Skąd odtworzyć kopię :
      1. Z pliku (wskaż plik archiwum) - zaznaczamy jeśli kopia znajduje na dysku stałym, pamięci typu flash, CD itp. Można ręcznie wpisać nazwę pliku kopii do odtworzenia i jego lokalizację lub nacisnąć przycisk Przeglądaj i wskazać plik kopii.
      2. Z serwera FTP (podaj identyfikator kopii) - jeżeli kopia ma zostać przesłana z PI Rol-Tech to wtedy zostanie ona umieszczona na serwerze FTP, a z PI Rol-Tech otrzymają Państwo identyfikator kopii (liczba z zakresu 1-9999). Ten identyfikator należy wpisać w to pole.
  3. Etapy odtworzenia kopii
      W trakcie odtwarzania kopii program :
    1. Sprawdza, czy w danej chwili nie jest wykonywana archiwizacja bądź odtwarzanie danych przez innego Użytkownika.
    2. Sprawdza, ,czy inny Użytkownik nie korzysta z baz danych zestawu, do którego odtwarzane są dane.
    3. Zabezpiecza aktualny stan danych na wypadek, gdyby odtwarzanie kopii zakończyło się nieprawidłowo, a pliki archiwum kopiuje do folderu tymczasowego - gdyby się coś nie powiodło dane te zostaną odtworzone.
    4. Następnie nastąpi dekompresja danych - pliki zostaną przesłane z kopii do wskazanego zestawu.
    5. Na końcu program usunie pliki tymczasowe powstałe przy odtwarzaniu kopii oraz pliki indeksowe zestawu. Ponieważ odtwarzane pliki mogą nie być odpowiednie dla bieżącej wersji oprogramowania, koniecznie trzeba wykonać zaktualizować struktury baz danych do bieżącej wersji oprogramowania. Można to zrobić na dwa sposoby :
      1. W oknie Akceptacja odtwarzania archiwum (kopiowania plików do zestawu) zaznaczyć opcję Wykonaj aktualizację struktur baz danych do aktualnej wersji - wtedy po odtworzeniu kopii program automatycznie wykona aktualizację struktur baz danych. Opcja ta jest załączona domyślnie.
      2. W przeciwnym, razie należy wykonać funkcję Aktualizacja struktur baz danych.
  4. Odtwarzanie baz startowych
      Jeśli zajdzie taka potrzeba można (oprócz danych zestawu) odtworzyć bazy startowe (konfiguracyjne)., o ile takie są zawarte w odtwarzanej kopii. Są one automatycznie umieszczane w kopii, które zostały wykonane programami o wersji kompilacji równej lub wyższej 1.4x.0701. Programy w niższej wersji nie dołączały tych baz do kopii. O tym czy w kopii ją te dane program poinformuje w oknie Akceptacja odtwarzania archiwum (kopiowanie plików do zestawu). Jeśli takie dane są w kopii pojawi się opcja Odtwórz bazy startowe i po jej załączeniu bazy zostaną odtworzone. Te bazy zawierają informacje o firmach, zestawach i operatorach zarejestrowanych w programie i są zawsze używane przy starcie programów. Dlatego opcji tej należy używać ostrożnie tylko w wypadku, kiedy jest to niezbędne np. bazy startowe zostały uszkodzone.

Patrz także

Kopie danych (kopie bezpieczeństwa) | Projekty kopiowania | Wykonanie kopii danych | Identyfikacja kopii


Menu - Projekty kopiowania

  1. Przeznaczenie
      Projekt kopiowania pomaga Użytkownikowi w prosty sposób zarządzać zabezpieczaniem danych.
      Można tworzyć wiele projektów - sposobów kopiowania danych z uwzględnieniem możliwości stanowisk komputerowych operatorów. Np. inne właściwości ma projekt kopiowania na CD (może być uruchomiona aplikacja nagrywarki), a inne projekt kopiowania na dysk połączony przez USB.
  2. Parametry projektu
      Na dane określające właściwości projektu składa się symbol, opis projektu oraz parametry zakładki Plik archiwum i zakładki Pozostałe właściwości.
    1. Symbol- oznaczenie projektu. Długość symbolu do 30 znaków.
    2. Opis - Dowolna treść identyfikująca symbol projektu. Długość opisu do 120 znaków.
    3. Umieszczaj archiwum w subfolderze o nazwie RRRR_MM_DD - Kopia danych zostaje zapisana w subfolderze, którego nazwę tworzy data wykonania kopii. Nazwa zawiera rok, miesiąc, dzień poprzedzielane podkreśleniem, np. 2006_06_01.
    4. Usuwaj bez powiadomienia ostatnio wykonane archiwum o ile ma taka samą nazwę - Zaznaczenie opcji powoduje, iż poprzednia kopia o takiej samej nazwie w tym samym folderze usuwana jest automatycznie. Przy odznaczonej opcji w trakcie wykonania kopii program zapyta o usunięcie archiwum.
    5. Dodatkowo archiwum kopiuj do folderu - Można wskazać folder do kopiowanie kopii na inny dysk stały, pamięć typu flash, itd. W zakładce 'Pliki archiwum' w opcji 'Dodatkowo archiwum kopiuj do folderu' należy wskazać pełną ścieżkę na folder kopi. Przy wykonaniu kopiowania we wskazanym folderze kopia wcześniejsza o takiej samej nazwie będzie zastępowana kopią bieżącą.

Patrz także

Kopie danych (kopie bezpieczeństwa) | Wykonanie kopii danych | Odtworzenie kopii danych | Identyfikacja kopii


Menu - Identyfikacja kopii

    Funkcja jest przeznaczona do identyfikacji kopii. Czasami sam opis na CD lub dyskietce nie wystarcza do jednoznacznego stwierdzenia jaki jest stan danych zawarty w kopii. Dzięki tej funkcji można łatwo sprawdzić co znajduje się w kopii danych.
  1. Dane identyfikacyjne zawarte w kopii to :
    1. Program, który przygotował kopię.
    2. Dla jakiej jest firmy wykonana była kopia.
    3. Z jakiego zestawu danych została wykonana kopia.
    4. Czy kopia zawiera bazy startowe (konfiguracyjne).
    5. Kiedy ją wykonano ( dzień i godzina).
    6. Kto ją wykonał ( symbol i nazwa operatora).
    7. Jakim wersją programu ją wykonano oraz z którego dnia i godziny pochodzi program.
    8. Folder systemu, firmy i zestawu danych na z którego wykonywano kopię.
    9. Folder archiwum ( z pełną ścieżką dostępu ) na którym jest zapisana kopia.
    10. Opis wprowadzony przez Użytkownika dla lepszego zrozumienia stanu plików w zapisanej kopii.
  2. Identyfikacja kopii z plików będących na dysku twardym, CD lub pen-drive'ie
      W polu Wskaż gdzie znajduje się kopia należy podać nazwę pliku wraz lokalizację (folderem). Do wspomagania znalezienia piku służy przycisk "Przeglądaj".
      Po wybraniu plku z kopią naciskamy przycisk "Wykonaj".
      Po tym pojawi się okno Identyfikacja kopii danych, w którym znajdować się będą informacje o kopii - jak opisane w punkcie A.
  3. Uwagi
    1. W polu opisanym Wskaż, gdzie znajduje się kopia domyślnie będzie się pojawiać lokalizacja folderu Archiwum, ustawiona w module konfiguracyjnym.
    2. Możemy ręcznie wpisać lokalizację i nazwę kopii. Wówczas program sprawdzi czy w podanej lokalizacji znalazł plik o zadanej nazwie. Zamiast wprowadzania ręcznego można wskazać kopię przyciskiem 'Przeglądaj'. Pojawi się standardowe okno wyboru pliku w Windows,
    3. Jeśli identyfikujemy kopię na innym nośniku niż dysk stały nośnik musi być fizycznie podłączony do komputera i 'widziany' przez Windows,

Patrz także

Kopie danych (kopie bezpieczeństwa) | Projekty kopiowania | Wykonanie kopii danych | Odtworzenie kopii danych


Informacje techniczne

    Rozdział ten zawiera informacje o lokalizacji plików, ich znaczeniu oraz zawartości.
  • Rozmieszczenie plików - lokalizacja plików programu.
  • Bazy i pola danych - opis baz, struktur i zawartości informacyjnej (pól) baz danych.


Rozmieszczenie plików

    W czasie instalacji tworzone są foldery, w których umieszczane są pliki. W trakcie pracy plików i folderów może przybywać lecz ich lokalizacja i zawartość informacyjna będzie zgodna z poniższymi zasadami.
  • Folder Instalacyjny - folder, który został podany w czasie instalacji jako folder programów (serwera).
      Znajdują się w nim pliki o rozszerzeniach :
    • EXE, APP - programy.
    • CHM - pomoc.
    • RT, IN - bazy startowe i konfiguracyjne> oraz ich indeksy.
    • LIC - klucz licencyjny.
    • FTP - plik konfiguracyjny do połączeń z serwerami FTP.
    • TXT, XLS, XML - wydruki, jeżeli nie są umieszczane w indywidualnych folderach Użytkowników na podkatalogu _wydruki .
      Oraz foldery zawierające pliki :
    • _archiwum - do przechowywania kopii danych.
    • _tmp - pliki tymczasowe.
    • _klient - pliki niezbędne dla wywołań programów (skrótów).
    • _wydruki - zawiera indywidualne foldery dla wydruków Użytkowników.
    • _formularze - pliki PDF używane przez program do edycji i drukowania formularzy.
    • _instalacja - zawiera pliki instalacyjne, które byłu użyte do instalacji lub w ostatniej aktualizacji.
    • Nazwa_Firmy - folder z danymi firmy Nazwa_Firmy (może mieć długość do 30 znaków). Będzie ich tyle ile firm zdefiniowanych w programie.
        Każdy folder Nazwa_Firmy zawiera podfoldery. Nazwy są zależne od programu :
      • YYYY - rok z danymi firmy (RT, ST).
      • PLC, KEDU (Płace).
      • Dane, Szablony, Wyniki (Analizy XLS)
  • Folder Skrótów - folder, który został podany w czasie instalacji jako folder skrótów do programów (klienta) .
      Znajdują się w nim skróty do programów. Mogą one też zostać umieszczone na Pulpicie.
  • Folder dla bibliotek DLL i OCX
      Lokalizacja tego folderu zależy od wersji systemu operacyjnego Windows :
    • Dla systemów 64 bitowych - Windows\SysWow64
    • Dla systemów 32 bitowych - Windows\System32
    • Dla systemów 16 bitowych (Win98) - Windows\System.
      Do folderu systemowego Windows kopiowane są pliki :
    • VFP7R.DLL i VFP7RENU.DLL - biblioteki startowe FoxPro.
    • MCSOMCTL.* ; MSCOMM32.* ; MSMAPI32.* ; MSVCR70.DLL ; MSVCR71.DLL - biblioteki wykorzystywane przez program. Pliki te mogły być już zainstalowane przez inne programy. Jeśli tak było instalator pominie ich instalację.
    • ChilkatFtp2.dll - biblioteka obsługująca FTP.
    • DebenuPDFLibraryAX0912.dll - biblioteka obsługująca pliki PDF;
    • RTAPIWIN.DLL ; RTCAB.DLL - biblioteki niezbędne do funkcjonowania programu autorstwa PI Rol-Tech.
  • Programy nie dokonują żadnych wpisów do rejestrów Windows.


Bazy i pola danych

Każdy program ma bazy niezbędne do jego funkcjonowania. Informacje o nich: nazwy, struktury i zawartość informacyjna (pola danych) są zawarte w plikach pomocy (*.CHM) przeznaczonych do danego programu. Pomoc można wywołać z menu programu - Pomoc->Tematy pomocy. Informacje te są umieszczone w rozdziale Informacje techniczne.
W programach, bazach danych oraz plikach konfiguracyjnych polskie znaki zapisywane są w standardzie Windows-1250.


6. Dane wprowadzane do Systemu

    Do systemu wprowadzane są następujące dane
  • podstawowe:
    • typy dokumentów,
    • plan kont finansowych,
    • dane kontrahentów,
    • definicje rejestrów VAT,
    • parametry działania (deklaracje),
  • bieżące:
    • bilans otwarcia,
    • dowody finansowe.
    Na podstawie tych danych uzyskać można (do przeglądania i w formie wydruków):
  • dziennik księgowań,
  • kartoteki finansowe,
  • rejestry VAT (zakupu i sprzedaży),
  • sprawozdania: bilans, rachunek zysków i strat, przepływy pieniężne, F - 01
  • rożne zestawienia.
    Wszystkie dane roku obrachunkowego są dostępne przez cały czas. System daje możliwość bezpośredniego dostępu do innych lat - ilość przechowywanych lat zależy jedynie od pojemności dysku. Bilans otwarcia nie stanowi obrotów dziennika - dowód BO jest przechowywany osobno przez cały rok obrachunkowy. Program przechowuje dane miesięcznie tj. dane z każdego miesiąca są dostępne przez cały rok wraz z sumami miesięcznymi. Można wykonać każde zestawienie za dowolny miesiąc lub dowolne miesiące. Każde zdarzenie gospodarcze jest ewidencjonowane w formie jednego lub wielu dekretów finansowych stanowiących dowód finansowy. Można lecz nie ma obowiązku prowadzenia rejestrów VAT. Jeżeli nie prowadzi się rejestrów wszelkie operacje dotyczące VAT-u należy pominąć, nie ma to żadnego wpływu na przetwarzanie w module FK.


Dokumentacja

Niniejsze opracowanie stanowi wyciąg z dokumentacji Systemu w formie elektronicznej. Ma spełniać następujące zadania: ogólnie scharakteryzować System (zadania, możliwości i ograniczenia), umożliwić zainstalowanie na komputerze, przedstawić podstawowe zasady obsługi, rozpocząć pracę. Wszelkie szczegóły organizacyjne i techniczne znajdują się w dokumentacji programu, która jest dostępna w każdej chwili w czasie pracy programu - można ją także wydrukować.


Instalacja

    W skład pakietu instalacyjnego wchodzą następujące elementy:
  • Licencja. Zasady licencjonowania opisane są w dokumentacji programu Instalacja i aktualizacja ->Zasady licencjonowania.
  • Wyciąg z dokumentacji w formie broszury formatu A5.
  • CD instalacyjne lub instalator programu pobrany ze strony PI Rol-Tech.
    Instalacja standardowa na pojedynczym komputerze lub sieciowa – dla wielu Użytkowników opisana jest w dokumentacji programu. Rozdział Instalacja i aktualizacja punkt Instalacja oprogramowania.Dokumentacja programu jest dostępna kontekstowo w każdej chwili działania programu (klawisz F1).


Konfiguracja

3. Konfiguracja sprzętu i środowiska System przeznaczony jest do pracy na komputerach typu IBM PC o konfiguracji minimalnej: PC, procesor Pentium 233 MHz, 512MB RAM, dysk stały - ilość pamięci uzależniona jest od wielkości danych, do zainstalowania i pracy potrzeba na starcie 100 MB, drukarka graficzna (laserowa lub atramentowa), igłowa o możliwości druku na papierze 15 cal., system operacyjny XP Professional lub nowszy. System może pracować w dowolnej sieci (Novel od wersji 5, Unix, Windows Serwer 2000 i nowszy), która akceptuje stacje robocze pracujące pod Windows ( wersji Windows '98 SE i wyższej ) oraz akceptuje pliki o nazwie dłuższej niż 8.3 (8 znaków nazwa podstawowa pliku i 3 znaki rozszerzenie). Systemy operacyjne Windows mogą być w wersji 32 lub 64 bitowej. W przypadku pracy w sieci konieczne jest dostosowanie rodzaju programów do posiadanego sprzętu, jeżeli pracujące komputery są różnych typów - realizacja tego jest już indywidualną sprawą Użytkownika.


Realizacja obiegu dokumentów

    Jest on następujący:
  • Dowody finansowe są wprowadzane do zbiorów roboczych operatora systemu i są widoczne tylko dla tego operatora. NIE są bezpośrednio przesyłane do dziennika i nie aktualizują kont. Wprowadzone dowody można sprawdzać przeglądając je lub drukując. Można również drukować rejestry VAT. Na tym etapie można dokonywać wszelkich zmian w dekretach.
  • Jeżeli dowody są prawidłowe i chcemy je przenieść na konta i do dziennika to wykonujemy księgowanie. W czasie tej funkcji sprawdzana jest poprawność formalna dekretów, struktury kont, bilansowanie się dowodów, a następnie po sprawdzeniu, że wszystko się zgadza następuje księgowanie.
  • Po wykonaniu funkcji księgującej dowody znajdują się w dzienniku i na kartotekach i są widoczne dla wszystkich operatów systemu mających dostęp do odpowiednich funkcji.
  • Rejestry VAT uzyskiwane są bezpośrednio z wprowadzonych dowodów lub z dziennika. Nie ma żadnej funkcji przenoszącej dekrety do rejestrów, ani osobnego wprowadzania danych do rejestrów. Rejestr jest tworzony na podstawie dziennika (lub wprowadzonych, lecz jeszcze nie zaksięgowanych dowodów) według parametrów zadanych przez Użytkownika.
  • Po zaksięgowaniu dowodów możliwe jest wykonywanie wszelkich zestawień (dziennik, kartoteki, obroty i salda, rejestry VAT itp.).


Podstawowe zasady obsługi

    Zasady obsługi programu są analogiczne do sterowania innymi programami.Tak samo działają kursory, klawisze edycyjne (PGUP , PGDN itp.) tam gdzie są aktywne klawisze specyficzne dla danej funkcji jest to opisane. Zapis Ctrl + F5 oznacza, że należy nacisnąć i przytrzymać klawisz Ctrl i jednocześnie nacisnąć F5. W całym Systemie następujące klawisze mają zawsze to samo znaczenie:
  • Esc - Wyjście z funkcji programu, powrót do menu.
  • Enter - Wybór, aktualizacja , przeglądanie.
  • Insert (Ins) - Dopisywanie dokumentu, pozycji.
  • Delete (Del) - Kasowanie dokumentu, pozycji.
  • Enter - Przeniesienie wybranej wartości w edytowane pole.
  • F1 - Pomoc, wywołanie dokumentacji programu.
  • F3 - Wywołanie kalkulatora Windows.
  • F4 - Przejście do okna wydruków zapisanych na dysk (txt, xls).
  • F5 - Przejście do wybranego dokumentu.
  • F6 - Przejście do drukowania , gdy jest dostępny przycisk „Drukuj”.
  • F7 - Zmiana kolejności danych.
  • F12 -Pomoc na polach podświetlonych zielonym kolorem, naciśnię cie klawisza F12 spowoduje wyświetlenie podpowiedzi (wartości, które można wprowadzić w to pole).
  • Alt+X - Koniec pracy programu
  • Alt+F2 - Wywołanie darmowego pakietu OpenOffice (jeśli aplikacja jest dostępna w danej lokalizacji).
  • Alt+F3 - Wywołanie kalkulatora taśmowego.
  • Ctrl+Enter - Edycja nagłówka i stopki dokumentu.
  • Ctrl+End - Akceptuj dokument.
  • Ctrl+F2 - Wywołanie Microsoft Excel (jeśli aplikacja jest dostępna w danej lokalizacji).
  • Ctrl+F3 - Notatnik tekstowy Windows.
  • Ctrl+F5 - Wyszukiwanie zaawansowane.
  • Shift+F2 - Wywołanie Microsoft Word (jeśli aplikacja jest dostępna w danej lokalizacji).


Zasady przetwarzania okresu obrachunkowego

    Składają się na to następujące etapy:
  • Rozpoczęcie roku może być wykonywane na dwa sposoby:
    • wprowadzenie danych ręcznie (w przypadku rozpoczynania pracy z programem po raz pierwszy),
    • poprzez wykonanie funkcji „Otwarcie nowego roku” (w przypadku przetwarzania kolejnego roku), która automatycznie:
      • przeniesie dane z poprzedniego roku. Oba sposoby mają za zadanie wprowadzenie danych podstawowych,
      • ustawienia parametrów roku (początek, koniec, miesiące, parametry systemowe),
      • zdefiniowania typów dokumentów finansowych,
      • wprowadzenie planu kont,
      • wpisania danych kontrahentów,
      • określenia rejestrów VAT,
      • wprowadzenia BO.
      Oczywiście dane te można w miarę potrzeby uzupełniać o nowe elementy (dopisywanie nowych kont, rozwijanie kont o nowe analityki, zmiany w definicjach rejestrów VAT itd.).
  • Przetwarzanie kolejnych miesięcy. Po rozpoczęciu roku kolejno przetwarzany jest każdy miesiąc. Składa się na to powtarzanie cyklu (przetwarzanie bieżące): wprowadzenie i sprawdzenie dowodów, zaksięgowanie ich na konta, drukowanie zestawień. O tym, czy księgowanie odbywa się codziennie, raz na tydzień, czy raz na miesiąc decyduje Użytkownik. Można to robić w dowolnej chwili - należy jedynie pamiętać, aby dowody były poprawne formalnie (w innym przypadku program nie wykona księgowania). Po zaksięgowaniu wykonuje się zazwyczaj wiele rożnych czynności zależnie od potrzeb (rozliczanie kontrahentów, drukowanie zestawień, rejestrów VAT itp.). Po zakończeniu księgowań w danym miesiącu wykonuje się funkcję „Zamknięcie miesiąca”, która nadaje liczbę porządkową dziennika i następuje przetwarzanie następnego miesiąca.
  • Zakończenie roku. Po zaksięgowaniu wszystkich miesięcy wykonuje się otwarcie nowego roku (jak w punkcie a). Wykonanie ostatnich przeksięgowań np. na wynik finansowy można ułatwić za pomocą „Automatycznych przeksięgowań”. Otwarcie nowego roku nie zamyka dostępu do danych roku poprzedniego. Za pomocą funkcji „Loguj” można przełączać się pomiędzy wybranymi latami i zestawami danych. Po otwarciu nowego roku dokonuje się koniecznych zmian w planie kont i innych słownikach, po czym rozpoczynamy księgowania w nowym roku.


Wersje - zmiany

2. Podstawowe dane organizacyjne

  • Możliwość pracy w sieci (nieograniczona liczba stanowisk),
  • Zmienna długość roku obrachunkowego: od 1 do 24 miesięcy,
  • Rok obrachunkowy może być rożny od roku kalendarzowego (np. Maj 20012 - kwiecień 2013),
  • Możliwość prowadzenia księgowości dla Jednostek Organizacyjnych (oddziałów, filii, wydziałów) gdzie suma kont JO = konto Przedsiębiorstwa,
  • Prowadzenie dodatkowo kont ilościowo - wartościowych (dla 2 jednostek miary),
  • Całkowita długość konta: 10 znaków,
  • Ilość poziomów kont: do 5 (syntetyka, subsyntetyka, analityka1, analityka2,, analityka3),
  • Każda syntetyka może mieć subkonta (analityki),
  • Można określić indywidualny poziom konta dla każdej syntetyki,
  • Automatyczne księgowanie na konta wyższego poziomu dla dekretów analitycznych,
  • Automatyczne pobieranie stanów bilansu zamknięcia jako bilans otwarcia w roku następnym,
  • Prowadzenie rozliczeń z kontrahentami,
  • Edycja przelewów.


Start

Informacje prawne

Zgodnośc z ustawa o rachunkowości

Copyright (c) 2012 PI Rol-Tech


Kopie danych (kopie bezpieczeństwa)

    W przypadku awarii dysku lub całego komputera konieczne jest ponowne zainstalowanie oprogramowania i odtworzenie kopii danych. O ile programy są zawsze dostępne - można je otrzymać od PI Rol-Tech, jeżeli nie posiadają Państwo programu instalacyjnego (setup'a), to z danymi sprawa jest bardzie j skomplikowana. Bowiem one zmieniają się z dnia na dzień. Wykonywanie kopii danych jest jedną z najważniejszą rzeczy, o której MUSI pamiętać osoba administrująca (zarządzająca) programem. Kopie trzeba wykonywać zawsze kiedy dane ulegają zmianie - najlepiej codziennie. W tym celu w programie znajdują się funkcje do wykonywania i odtwarzania kopii danych.
  1. Co zawiera kopia ?
      Kopia zawiera dane jednej firmy. Stan danych w kopii jest taki, jaki był w chwili jej wykonania. Jeżeli nie ma pewności, co jest w kopii (bo np. brak opisu na CD) to można zidentyfikować ją za pomocą funkcji Identyfikacja kopii.
  2. Projekty kopiowania
      Sposób w jaki będą kopiowane dane firmy - do jakich plików, gdzie, itp. określany jest jako projekt kopiowania. Projekty pomagają Użytkownikowi w prosty sposób zarządzać zabezpieczaniem danych. Projekty definiuje się w funkcji Projekty kopiowania.
      Projekt kopiowania nie określa jaka firma ma być kopiowana. Decyduje o tym Użytkownik wykonując kopię danych. Odtwarzanie kopii również w żaden sposób nie jest powiązane z projektem.
  3. Wykonanie kopii
      Kopię wykonuje jedna osoba w chwili kiedy nikt nie jest zalogowany do kopiowanej firmy. W celu późniejszej identyfikacji kopii najlepiej jest wprowadzić opis przy wykonaniu kopii. Kopię wykonuje się w funkcji Wykonanie kopii. Zostanie ona wykonana zgodnie z projektem.
  4. Odtworzenie kopii
      Kopię odtwarza jedna osoba w chwili kiedy nikt nie jest zalogowany do odtwarzanej firmy. Wykonuje się to w funkcji Odtworzenie kopii. Po odtworzeniu należy wykonać funkcję Indeksowanie baz danych.


Menu - Wydruki wykonane na dysk

  1. Przeznaczenie i sposób wywołania
      Funkcja jest przeznaczona do zarządzania wydrukami wykonanymi na dysk w postaci pliku. Taka możliwość istnieje dla wydruków wszystkich postaci oprócz graficznej. Przy drukowaniu w postaci graficznej wydruk jest przesyłany do sterownika drukarki, a nie do pliku i dlatego nie są brane pod uwagę w tej funkcji.
      Funkcję można wywołać na dwa sposoby :
    1. Wybierając pozycje z menu głównego - Inne->Wydruki na dysku.
    2. Naciskając w dowolnej chwili klawisz F4.
  2. Opis okna
      Okno można podzielić na 3 części
    1. W górnej części pasek przycisków,
    2. Poniżej umieszczone są informacje jakie pliki są wyświetlane na liście. Lokalizacja plików jest podana w polu Folder. Sposób wyświetlania można zmieniać :
      1. kolejność wyświetlanych plików,
        1. Nazwa (A..Z) - wzrastająco
        2. Nazwa (Z..A) - malejąco
        3. Rozmiar (1..99)- wzrastająco
        4. Rozmiar (99..1) - malejąco
        5. Wykonanie (0.00..24.00) - wzrastająco
        6. Wykonanie (24.00..0.00) - malejąco
      2. postać (rodzaj) plików : :
        1. Pliki tekstowe -Wydruki z programu przechowywane sa jako pliki tekstowe z rozszerzeniem TXT .
        2. Arkusze Excel`a - Pliki z rozszerzeniem XLS.
        3. Pliki XML - Wydruki z OpenOffice`a. Wydruki z rozszerzeniem XML.
        4. Pliki PDF - Pliki obsługiwane przez Adobe Reader.
    3. Resztę okna zajmuje lista plików.
  3. Co można zrobić z wydrukiem ?
      Wykonane na dysk wydruki możemy przeglądać, drukować, edytować, usuwać. By móc edytować plik z rozszerzeniem XLS musimy posiadać licencjonowany program Excel - do obsługi arkuszy kalkulacyjnych. .By móc edytować plik z rozszerzeniem XML musimy posiadać OpenOffice - do obsługi arkuszy kalkulacyjnych. Dla plików PDF konieczne jest zainstalowanie programu Adobe Reader. Przyciski realizują następujące czynności
    1. Przeglądaj - dla XLS wywołany zostanie Excel, dla XML OpenOffice, dla PDF program Adobe Reader.
    2. Zapisz jako - zapisanie (kopiowanie) wydruku w podanej lokalizacji.
    3. Usuń - usunięcie wydruku.
    4. Drukuj - Drukuje wydruk. Tylko dla postaci tekstowej. Excel, OpenOffice, Adobe Reader mają swoje funkcje drukujące.


Menu - Indeksowanie baz danych

    Funkcja tworzy na nowo pliki indeksowe, które są niezbędne do pracy w programie. Funkcja wykonywana jest z przyczyn technicznych, np.: w przypadku wyłączenia komputera w trakcie pracy programu, spadku napięcia elektrycznego, itd. lub odtworzenia kopii.
    Indeksowane mogą być wybrane firmy. Warunkiem wykonania indeksowania zestawu firmy jest wylogowanie się i zakończenie pracy przez innych użytkowników. Program nie pozwala na indeksowanie baz danych, na których pracuje użytkownik.
  1. Wybór firm
      W oknie są 2 listy :
    1. Po lewej stronie firmy które mają być indeksowanie.
    2. Po prawej stronie firmy, które istnieją, ale nie będą indeksowane.
      Za pomocą przycisków znajdujących się pomiędzy listami można przesuwać firmy tak, aby wybrać te, które chcemy indeksować.
  2. Wykonanie indeksowania
      Indeksowanie uruchamia się przyciskiem Indeksuj - zostanie ono wykonane dla wybranych firm.